Cinema 4D Exporter Update

Back to overview
Edit: We’re aware of plugin installation issues on some machines. Please leave a comment including your Cinema 4D version, Operating System, system/application language and your plugin directory. Or, you can email this information to support@sketchfab.com. Thanks for your patience as we investigate.

Good news for Cinema 4D users! We have updated the Cinema 4D exporter to support animations so you can now use it to upload your FBX files.

The Sketchfab Exporter makes it super easy for you to share your C4D creations and work in progress on Sketchfab. It lets you publish your static and animated models straight from Cinema 4D to Sketchfab in just a few clicks. Here is a quick video:

 

How it works

  • Open your scene in Cinema 4D.
  • Go to File → Save project with Assets… to collect your model and textures together.
  • Open the Sketchfab Exporter plugin from the Plugin menu.
  • Enter a title, description, and tags, and mark it as Private if necessary.
  • Enter your API token, which you can save for later under Options.
  • Click Publish!

Using the Cinema 4D exporter will tag your model with ‘Cinema4D’ so it shows up in the gallery and will also add an “Uploaded with Cinema 4D” icon to your model page, like so:

image

As always, we always welcome your feedback, so if you do come across any issues, let us know.

Looking forward to seeing your Cinema4D animations!

About the author

Avatar

Natalia Krasnodebska

Previously Head of Communications at Sketchfab, now Jewelry designer at bynatalia.com


Leave a Reply

Your email address will not be published. Required fields are marked *

  • Avatar Gabriel says:

    Doesn’t work on C4D R15! :/

  • Avatar LUIGI says:

    Doesn’t work on C4D R17! :/

  • Avatar Scott says:

    Doesn’t work, Windows 10, R17. Error is “Unable to upload model to Sketchfab.com. Reason: must be string without null bytes or None, not str”

  • Avatar chris says:

    “The Sketchfab Exporter makes it super easy for you to share your C4D creations and work in progress on Sketchfab.”

    If “super easy” means it never works, then yes, it SUPER EASY!

  • Avatar Dariusz says:

    Doesn’t work on C4D R15! It can not be installed. Is there an explanation?

  • Avatar Bondiana says:

    Doesn’t work on C4D R14. I’m on mac and it doesn’t appear on the plunging menu after I paste and reload the program.

  • Avatar Gary says:

    Hi. Looks like this plugin doesnt work proper for different c4d version i have r15 and it doesnt work. My question when you will have update for c4d that it will work on all c4d versions?

  • Avatar VF says:

    It doesn’t work in version R14 neither in the R17 version (Windows 10 x64).

  • Avatar DE says:

    is it possible to reupload a cinemea4d file in Sketchfab via plugin?

  • Avatar Hanninen says:

    Doesn’t work on C4D R18 (Windows 10). Unable to upload model to Sketchfab.com. Reason: Export failed.

  • Avatar Scott says:

    For anyone having issues with exports. Here are two things I found that were causing export issues for me.

    1. If the c4d file is in a gDrive or Dropbox folder. Pausing the syncing then run the export worked, my dropbox catalog is pretty big and I think the delay of it trying to sync was causing plugin to fail.

    2. Make sure your model name doesn’t have any special characters like “/” in it. Using forward slashes in my model names would cause the export to fail.

    Hope this helps someone!

  • Avatar Crist says:

    For me, it doesn’t appear in the plugins window

    Cinema 4d R14
    Windows 7
    32x bits

  • Avatar Richard says:

    I am experiencing the same the plugin does not appear in the c4d-menu under plugins??

    Cinema 4d R15
    Mac OS 10.11.6

  • Avatar James Green says:

    Hi everyone,

    We’re aware of install issues on some machines. Thanks for you reports and your patience as we investigate. Please comment with Cinema 4D version, Operating System, and any other information like system language and plugin directory.

    The current workaround to manually export and upload FBX.

    Cheers,
    James

  • Avatar Cannoli says:

    It’s not working for me on C4d r17 Windows 7 and 10

  • Avatar bart says:

    Doesn’t work on C4D R18 (Mac os Sierra).
    Unable to upload model to Sketchfab.com. Reason: Export failed.

  • Doesn´t work on C4D 18 Visualize (Windows)
    Export failed.

  • Avatar Jose says:

    Doesn’t work on C4D R14 (Mac Os Sierra)
    No appear in the plugins window… 🙁

  • Avatar Peter says:

    Doesn’t show up in the plugins menu. R13.061 on MacOS Sierra 10.12.1

  • Avatar James Green says:

    Thanks everyone. We’re still listening and collecting information, but we don’t have an update for you yet. Thanks for your patience and sorry for the inconvenience.

  • Avatar Sigi says:

    Doesn’t work on C4D R18 (OSX Yosemite, Version 10.10.5). Unable to upload model to sketchfab.com. Reason: Export failed.

  • Avatar Chris says:

    🙁 Doesn’t work on C4D R18. WIN 7 64bit “Unable to upload model to sketchfab.com. Reason: Export failed.”

  • Avatar Jesse Ekholm says:

    Keeps crashing the program everytime I try to upload my scene. Im running R18 on OSX Sierra. My scenes are using another plugin called CineDesigner (cinematographydb.com) maybe it’s the one causing problems?

  • Avatar luis says:

    Sorry, I think the plugin is coming soon because I plan to buy the pro package but I only use cinema4d.
    🙁

  • Avatar Sebastian says:

    I have the R17 Student version on Windows 10 and get an “HTTP Error 400: Bad Request” when I try to upload. Any solutions?

  • Avatar MrDragoster says:

    How to install this exporter? Say me please!!!

  • Avatar Attila Z. Kedei says:

    A year passed and the plugin is still broken… Are you for real?

    • Avatar James Green says:

      I’m sorry, we know it’s still an issue and that it’s been going on for a long time.

      We still do not have a fix, but we do hope to spend some time on this soon.

  • Avatar Joe Gourley says:

    I keep getting export failed. I am using Sketch Fab with a MAC Sierra version 10.12.3 the software is Cinema 4d R18 Studio

  • Avatar Dani says:

    goodmorning,

    i have w7PRo and C4dR14 but plugin doesn’t work

  • Avatar Emre Telci says:

    Doesn’t work on C4D R15! Never appears on plugin window.
    Mac OS X 10.12.6

  • Avatar Chris Nicholaidis says:

    C4D R18 crashes the system

  • Avatar Alan says:

    C4D R14 here. Same problem as other people.
    Doesn’t show up under plugins.
    Both on OS X Sierra as Windows 10

  • Avatar Craig Tweed says:

    I am using the latest Cinema 4D Studio R19 and exporting a 3d model using the plug-in SketchFab that causes an immediate software crash.

    MAC Platform
    macOS Sierra version 10.12.6
    Mac Pro – Late 2013
    3 Ghz 8-Core Intel Xeon E5
    Memory 64 GB 1866 MHz DDR3
    Graphics AMD FirePro D500 3072 MB

  • Avatar Cody says:

    Same problem as everyone else. I decided to check the python console to see what it was saying the problem was. It’s saying there is a problem with the exporter.py script on line 104 in Attribute Error: module object has no attribute ‘FBXExport_Lights’ … That being said i’m going to go out on a limb and assume it’s a lighting module issue causing the problems. I’m running

    Win 7 64 bit
    8gb DDR3
    Geforce GT 630 GPU 2gb
    Amd Athlon X3 over clocked to 3.30ghz
    Maxon Cinema 4D R15

    ————– Screen shot of the error code within the python console——–
    http://puu.sh/yxZAE/577d82e045.png

  • Avatar Q says:

    Still not working. Really unfortunate, I know there are alot of c4d users that would like to be a part of the community. C4d r19 on mac OS 10.12.6
    Any progress sketchfabb?

  • Avatar Marc Dubois says:

    the plugin It’s a BIG SHIT, it crash Cinema 4d R18 19 !!! on mac os x 10.12.6

    We waste a lot of time these are not professional tools, the management of textures is very complicated, the export also, the UVs are very poorly managed, except with the format Collada but the files are much bigger and I have to pay for upload it, moreover the rendering is not terrible

  • Avatar Marc Dubois says:

    Why should I pay for tools that don’t work? I am an independent graphic designer and made 3d for 10 years and I have never seen tools like Sketchfab as mediocre

  • Avatar Paul says:

    STILL not working? Please advise on a fix time frame -this is getting ridiculous. If no support is planned, please advise so we can move on to other things and not waste time and patience on something that is never going to materialise. Thanks.

    Cin4D Studio – R15 on both Mac High Sierra and Win 10.

  • Avatar ProductRenders says:

    Doesn’t work in R18 on Mac running 10.12.6.
    Looking at the comments it doesn’t seem to work on any version of C4D 🙁

  • Avatar Nyx says:

    Doesn’t work on C4D R19…

    Windows 10
    Amd FX-8350
    Asus GTX 750ti oc

  • Avatar dav888 says:

    wheres the exporrter file????

  • Avatar Jamal Qutub says:

    On my Windows 10 machine, the Plugin doesn’t load at all in C4D R20 and in R19 I get an HTTP error.

  • Avatar Mike McKean says:

    Hi! The exporter doesn’t seem to save my normal data. My low poly model looks smooth in C4D (via Phong tags) but faceted in Sketchfab. R19, Windows 10. Any ideas? Are there possibly extra export settings I can get into? Thanks!

  • Avatar Dale Jackson says:

    Does not show up in Cinema 4Dr 19 or r20

  • Avatar Greg Sparkman says:

    Just tried to use the exporter in R16 on Mac OS X “High Sierra”. I’ve used it successfully in the past. Now it’s failing.
    Reason:

  • Avatar Marion says:

    Unable to upload model to Sketchfab.com. Reason: urlopen error [Errno 1] _ssl.c:480: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

    Please, Help?
    Cinema r17 / Mac osx High Sierra.

  • Avatar Paul Knight says:

    Come on Sketchfab – this issue should have been resolved ages ago. What is the justification for such a long period without a solution? Its not like C4D users are a very minor user group.
    Please advise!

  • Avatar Josef says:

    Doesnt work on R20

  • Avatar Orghal says:

    Doesn’t work with R17 🙁 trying with folder plugins, and manually unpack what is in description – python, but nothing. I see something in plugins manager but in the plugins menu, nothing. No effect. Any help? Windows 10 🙁

  • Avatar manuel davoin says:

    how to install en C4D R20

  • Avatar Emanuel López says:

    Will they continue to investigate why it does not work?

Related articles