How to clean up Oculus Medium files and publish them on Sketchfab

Back to overview

Oculus recently released Medium, their new VR sculpting and painting app. And almost immediately, we saw an influx of exciting art by VR artists. The uploads are not without issues though and some people indicated not being able to publish their work on Sketchfab: the models have ‘cracks’ in the mesh which breaks the shading, and the resulting files are BIG.

Fortunately, this is all easy to fix with some free software. This article by Ryan Schmidt takes you through the cleanup process step by step.  

This tutorial has been republished from the Oculus forum with the author’s permission. Ryan is also the author of Autodesk’s Meshmixer, and is currently working on Simplex, which he coins as the first VR-Native CAD Tool.

Update: Oculus Medium informed us that the seams should now be properly welded.

We fixed the seam welding thing in one of our point releases in December. You should not see those cracks (the blue edges in meshmixer) any more.

Let’s go!

I see a few people posting about using Medium sculpts in other apps. This is a bit tricky because the exported meshes have (1) high polycounts and (2) lots of cracks. I will describe a way to repair this, that will produce a mesh you can cleanly import into other tools for further editing (zbrush, mudbox, etc).

This workflow uses Autodesk Meshmixer (I was the author of that software, so you are getting all the secrets 😉 Meshmixer is free, get it here.

A Medium export might look nice in Meshlab, but if you import into Meshmixer you will see that it is filled with cracks (the blue edges). This, I would imagine, is due to how Medium piecewise-meshes the level set surface. These cracks will be a big problem if you try to edit the mesh in other software, but we can fix that up.


Load the exported OBJ into Meshmixer. If you don’t see the colors, hold down the spacebar and click on the blue smooth-shaded sphere that says Color next to it. Now click the Edit button on the left bar, then Close Cracks. This will resolve most of the problems. Or it will crash Meshmixer. If the latter…sorry! That is literally my fault. You should get a pretty clean mesh, as shown below-right, but also possibly with some small issues (eg by the arrow).


It is a good idea to now export the model to OBJ and re-import after the Close Cracks step – this will significantly reduce the chance of later operations crashing.

Next up, open the Inspector tool under the Analysis tab. When you first start, you will probably see a ton of pink spheres. Drag the Small Thresh slider to 0 and they will go away, and instead you will see blue and/or red ones. Click on Auto Repair All. They should all go away. However, this might leave some small un-colored spots.


You can fix those spots in several ways, for example using the Paint Vertex brush (a bit of explanation in the manual). But another way is to Select that area and replace it, which will interpolate the neighbour colors. Images below show basically what to do – click Select on the left, paint a bit, then do Erase and Fill under the Edit submenu. I forgot to take an “after” picture, but rest assured, it is green. You can use this same process to clean up other little glitches, for example if the Auto Repair can’t fix something. Just paint it and Erase-and-Fill.


You might be happy with how the mesh looks now, but it almost certainly has far more triangles than necessary. This is because the Medium export mesh is created with some variant of the Marching Cubes algorithm, which produces lots of little sliver triangles. No other software wants that.

First, apply the Make Solid tool to get a solid, non-self-intersecting mesh. Next, do a Select-All by hitting Ctrl+a, then do Reduce under the Edit submenu. You should be able to safely drag the slider up to 75% without really changing the surface.


You can also try the Max Deviation mode, the default number will be too high but if you use lower values you’ll get better shape preservation for extreme reducing. Medium exports at very small dimensions, so if you can’t set the number lower in Reduce, try canceling out with Escape until the selection is cleared, then hit t to start the Transform tool (manual page here). Then click on the little white box in the 3D gizmo to scale up your model, and try again.

If you are losing too much detail, don’t do select-all, paint areas manually. double-clicking in the select tool will let you select whole connected areas. for example I probably should have left the teeth alone, they lost a bit of detail. For an even cleaner mesh, you can try the Remesh tool, but you probably want to read the manual page first.

Here is the original vs reduced version for the model above, at 75% reduction on the right. You’ll see it actually looks smoother. This is because all those little sliver triangles mess with the surface normal estimation, when you get rid of them, the smoothness of the shape comes through.


Happy sculpting! -RMS

Publishing your scene to Sketchfab

As mentioned before Medium files tend to be large, so be sure to perform the Reduce step to remove unnecessary geometry. To reduce file size even further, you can also combine your files into a compressed archive (ZIP, RAR, 7z). Make sure to include all the necessary files:

  • Your texture files (JPG, PNG, TIFF, TGA)
  • Your material file, if you’re using OBJ format (MTL)
  • Your model file

If after applying these steps and zipping your file it is still over 50MB, let us know!

Model before optimization

Model after optimization

About the author

Bart Veldhuizen

Community Lead at Sketchfab. 3D Scanning enthusiast and Blenderhead.


  • Nick C says:

    I’m trying to upload a project from oculus medium into sketchfab. I read the tutorial above, and it did help clean up my model. However after cleaning up the model when I try to upload to sketchfab there is no color or textures. Can anyone help?

  • Bart Veldhuizen says:

    Hi Nick, what is the URL of your model on Sketchfab?

  • Jerad Bitner says:

    You need to choose the option for “OBJ Format with Per-Vertex Color (*.obj)” in the “Save as type:” dropdown when you export. This will preserve your colors.

    You may want to add this to the tutorial Bart as I also had to go digging a bit for this problem.

  • FWIW – we fixed the seam welding thing in one of our point releases in December. You should not see those cracks (the blue edges in meshmixer) any more.

  • Bart Veldhuizen says:

    Thanks Brian! I’ll update the article with a notice.

  • Cyrus says:

    Hey! Thank you for your tutorial and software, works great excpect for one thing… I can seem to be able to export while retaining groups. Is there a way to do this? Thanks!

Leave a Reply

Your email address will not be published.

Related articles